Jump to content
Sign in to follow this  
CeMoore

I cant start up the game

Recommended Posts

Everytime i bring the client up and click start, nothing happends

Could i get some help?

Share this post


Link to post
Share on other sites

Right click celestia then go to open file location. Look for a file called "celestiapatch", delete it and restart the game

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks that worked, but now when ever i get to the server screen and click connect, my log in or anything doesn't pop up

Share this post


Link to post
Share on other sites

Turned off my Anti-Virus and re-installed it, and still have the same problem D:

Share this post


Link to post
Share on other sites

try that ^ step again (deleting celestiapatch)

Share this post


Link to post
Share on other sites

antivirus, firewall,and repatch,

it works for the other q.q

Share this post


Link to post
Share on other sites

That worked!, but is there maintnence cuz it says "failled to connect to Server Please check the website for latest information" Dx

Share this post


Link to post
Share on other sites

pfffffffffffffffffffffffffffffffffffffffff

try that again or check ur connection

*why I never experienced this problem before*

oh and

try running it as admin and using XP compatibility (if u are in win 7)

Share this post


Link to post
Share on other sites

UGGGHHHHHHHHHHHHHH i quit thx for the help tho Dx!!!!!!!!!

and is the last patch 09-2?

Share this post


Link to post
Share on other sites

UGGGHHHHHHHHHHHHHH i quit thx for the help tho Dx!!!!!!!!!

and is the last patch 09-2?

yea I guess...

duh wait, firewall... have u deactive it?

Share this post


Link to post
Share on other sites

no problem, glad to help :P

Case Closed!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...